$re = '/(?=[a-z0-9\/]*\d)(?<=[^:.-]\b)[\w\/]+(?=\b[^:.-])/mi';
$str = 'aaaaaaa bbb ccc dddddd A1/002, A/1002
A123, B123J, C1234JB, D2345JC
xxxx A123
B456 bbbbb bbbb ,b bbbb
12
23
24
55, 66, 77, 88
Xxxxx 55
66 yyyyy
aaa bbb ccc ddd
eeeeee fff gggggg
hhh ii jjjjj kkkkk
2011-11-11 11:11:11.000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);