const regex = /(?=[a-z0-9\/]*\d)(?<=[^:.-]\b)[\w\/]+(?=\b[^:.-])/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[a-z0-9\\\/]*\\d)(?<=[^:.-]\\b)[\\w\\\/]+(?=\\b[^:.-])', 'gmi')
const str = `aaaaaaa bbb ccc dddddd A1/002, A/1002
A123, B123J, C1234JB, D2345JC
xxxx A123
B456 bbbbb bbbb ,b bbbb
12
23
24
55, 66, 77, 88
Xxxxx 55
66 yyyyy
aaa bbb ccc ddd
eeeeee fff gggggg
hhh ii jjjjj kkkkk
2011-11-11 11:11:11.000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}