import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[a-z0-9\\/]*\\d)(?<=[^:.-]\\b)[\\w\\/]+(?=\\b[^:.-])";
final String string = "aaaaaaa bbb ccc dddddd A1/002, A/1002\n"
+ "A123, B123J, C1234JB, D2345JC\n"
+ "xxxx A123\n"
+ "B456 bbbbb bbbb ,b bbbb\n"
+ "12\n"
+ "23\n"
+ "24\n"
+ "55, 66, 77, 88\n"
+ "Xxxxx 55\n"
+ "66 yyyyy\n"
+ "aaa bbb ccc ddd\n"
+ "eeeeee fff gggggg\n"
+ "hhh ii jjjjj kkkkk\n"
+ "2011-11-11 11:11:11.000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}