using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^C[AFGJKL](?! ?\d{7}) ?\d+(?:[ -]\d+)?$";
string input = @"CA 123456
CF 1
CK 0467 21
CL 4 2
CG 456-789
CJ 1-23
And, if possible (optional), it should also match:
CA546
CJ99-0
CK8 0565
It should NOT match:
CZ 123456
C 987-123
CA 12345-
CK 12
CJ -456
CL-654
CJ 1234567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}