import Foundation
let pattern = #"^C[AFGJKL](?! ?\d{7}) ?\d+(?:[ -]\d+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CA 123456
CF 1
CK 0467 21
CL 4 2
CG 456-789
CJ 1-23
And, if possible (optional), it should also match:
CA546
CJ99-0
CK8 0565
It should NOT match:
CZ 123456
C 987-123
CA 12345-
CK 12
CJ -456
CL-654
CJ 1234567
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)