const regex = /^C[AFGJKL](?! ?\d{7}) ?\d+(?:[ -]\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^C[AFGJKL](?! ?\\d{7}) ?\\d+(?:[ -]\\d+)?$', 'gm')
const str = `CA 123456
CF 1
CK 0467 21
CL 4 2
CG 456-789
CJ 1-23
And, if possible (optional), it should also match:
CA546
CJ99-0
CK8 0565
It should NOT match:
CZ 123456
C 987-123
CA 12345-
CK 12
CJ -456
CL-654
CJ 1234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}