$re = '/^C[AFGJKL](?! ?\d{7}) ?\d+(?:[ -]\d+)?$/m';
$str = 'CA 123456
CF 1
CK 0467 21
CL 4 2
CG 456-789
CJ 1-23
And, if possible (optional), it should also match:
CA546
CJ99-0
CK8 0565
It should NOT match:
CZ 123456
C 987-123
CA 12345-
CK 12
CJ -456
CL-654
CJ 1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);