import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^C[AFGJKL](?! ?\\d{7}) ?\\d+(?:[ -]\\d+)?$";
final String string = "CA 123456\n"
+ "CF 1\n"
+ "CK 0467 21\n"
+ "CL 4 2\n"
+ "CG 456-789\n"
+ "CJ 1-23\n\n"
+ "And, if possible (optional), it should also match:\n\n"
+ "CA546\n"
+ "CJ99-0\n"
+ "CK8 0565\n\n"
+ "It should NOT match:\n\n"
+ "CZ 123456\n"
+ "C 987-123\n"
+ "CA 12345-\n"
+ "CK 12\n"
+ "CJ -456\n"
+ "CL-654\n"
+ "CJ 1234567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}