import re
regex = re.compile(r"^C[AFGJKL](?! ?\d{7}) ?\d+(?:[ -]\d+)?$", flags=re.MULTILINE)
test_str = ("CA 123456\n"
"CF 1\n"
"CK 0467 21\n"
"CL 4 2\n"
"CG 456-789\n"
"CJ 1-23\n\n"
"And, if possible (optional), it should also match:\n\n"
"CA546\n"
"CJ99-0\n"
"CK8 0565\n\n"
"It should NOT match:\n\n"
"CZ 123456\n"
"C 987-123\n"
"CA 12345-\n"
"CK 12\n"
"CJ -456\n"
"CL-654\n"
"CJ 1234567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")