package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Keyword1: (.*?)(Keyword2:|\\r\\n)`)
var str = `"Keyword1: That text I want \r\n Keyword2: Value2 \r\n Keyword3: Keyword2 \r\n Keyword4: Value4"
"Keyword1: That text I want Keyword2: Value2 \r\n Keyword3: Value3 \r\n Keyword4: Value4"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}