import re
regex = re.compile(r"Keyword1: (.*?)(Keyword2:|\\r\\n)", flags=re.MULTILINE)
test_str = ("\"Keyword1: That text I want \\r\\n Keyword2: Value2 \\r\\n Keyword3: Keyword2 \\r\\n Keyword4: Value4\"\n"
"\"Keyword1: That text I want Keyword2: Value2 \\r\\n Keyword3: Value3 \\r\\n Keyword4: Value4\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")