$re = '/Keyword1: (.*?)(Keyword2:|\\\\r\\\\n)/m';
$str = '"Keyword1: That text I want \\r\\n Keyword2: Value2 \\r\\n Keyword3: Keyword2 \\r\\n Keyword4: Value4"
"Keyword1: That text I want Keyword2: Value2 \\r\\n Keyword3: Value3 \\r\\n Keyword4: Value4"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);