use strict;
my $str = '"Keyword1: That text I want \\r\\n Keyword2: Value2 \\r\\n Keyword3: Keyword2 \\r\\n Keyword4: Value4"
"Keyword1: That text I want Keyword2: Value2 \\r\\n Keyword3: Value3 \\r\\n Keyword4: Value4"';
my $regex = qr/Keyword1: (.*?)(Keyword2:|\\r\\n)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}