const regex = /Keyword1: (.*?)(Keyword2:|\\r\\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Keyword1: (.*?)(Keyword2:|\\\\r\\\\n)', 'gm')
const str = `"Keyword1: That text I want \\r\\n Keyword2: Value2 \\r\\n Keyword3: Keyword2 \\r\\n Keyword4: Value4"
"Keyword1: That text I want Keyword2: Value2 \\r\\n Keyword3: Value3 \\r\\n Keyword4: Value4"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}