using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(d)|(D))(?:(a)|(A))(?:(t)|(T))(?:(e)|(E))\b";
string input = @"This Date is a DATE that is daTe and date.
But dated should not be replaced, and nor should sedate.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}