$re = '/\b(?:(d)|(D))(?:(a)|(A))(?:(t)|(T))(?:(e)|(E))\b/m';
$str = 'This Date is a DATE that is daTe and date.
But dated should not be replaced, and nor should sedate.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);