// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:(d)|(D))(?:(a)|(A))(?:(t)|(T))(?:(e)|(E))\b").unwrap();
let string = "This Date is a DATE that is daTe and date.
But dated should not be replaced, and nor should sedate.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}