re = /\b(?:(d)|(D))(?:(a)|(A))(?:(t)|(T))(?:(e)|(E))\b/m
str = 'This Date is a DATE that is daTe and date.
But dated should not be replaced, and nor should sedate.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end