const regex = /\b(?:(d)|(D))(?:(a)|(A))(?:(t)|(T))(?:(e)|(E))\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(d)|(D))(?:(a)|(A))(?:(t)|(T))(?:(e)|(E))\\b', 'gm')
const str = `This Date is a DATE that is daTe and date.
But dated should not be replaced, and nor should sedate.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}