import re
regex = re.compile(r"\b(?:(d)|(D))(?:(a)|(A))(?:(t)|(T))(?:(e)|(E))\b", flags=re.MULTILINE)
test_str = ("This Date is a DATE that is daTe and date.\n"
"But dated should not be replaced, and nor should sedate.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")