# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(p|div).*?\bstyle\s*=\s*.*?text-align:([a-zA-Z]+).*?>(.*?)<\/\1>/<\2>\3<\/\2>/gm;t' <<< "<p style=“text-align:center; others-style:value;”>Content</p>
<div style=‘text-align:left; others-style:value;’ class=‘any class’>Any Content That You Wish</div><p style=“text-align:center; others-style:value;”>Content</p>"