use strict;
my $str = '<p style=“text-align:center; others-style:value;”>Content</p>
<div style=‘text-align:left; others-style:value;’ class=‘any class’>Any Content That You Wish</div><p style=“text-align:center; others-style:value;”>Content</p>';
my $regex = qr~<(p|div).*?\bstyle\s*=\s*.*?text-align:([a-zA-Z]+).*?>(.*?)</\1>~mp;
my $subst = '<\\2>\\3</\\2>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";