import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(p|div).*?\\bstyle\\s*=\\s*.*?text-align:([a-zA-Z]+).*?>(.*?)</\\1>";
final String string = "<p style=“text-align:center; others-style:value;”>Content</p>\n"
+ "<div style=‘text-align:left; others-style:value;’ class=‘any class’>Any Content That You Wish</div><p style=“text-align:center; others-style:value;”>Content</p>";
final String subst = "<\\2>\\3</\\2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}