$re = '~<(p|div).*?\bstyle\s*=\s*.*?text-align:([a-zA-Z]+).*?>(.*?)</\1>~m';
$str = '<p style=“text-align:center; others-style:value;”>Content</p>
<div style=‘text-align:left; others-style:value;’ class=‘any class’>Any Content That You Wish</div><p style=“text-align:center; others-style:value;”>Content</p>';
$subst = "<\2>\3</\2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;