const regex = new RegExp('<(p|div).*?\\bstyle\\s*=\\s*.*?text-align:([a-zA-Z]+).*?>(.*?)</\\1>', 'gm')
const str = `<p style=“text-align:center; others-style:value;”>Content</p>
<div style=‘text-align:left; others-style:value;’ class=‘any class’>Any Content That You Wish</div><p style=“text-align:center; others-style:value;”>Content</p>`;
const subst = `<\2>\3</\2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);