import re
regex = re.compile(r"<(p|div).*?\bstyle\s*=\s*.*?text-align:([a-zA-Z]+).*?>(.*?)</\1>", flags=re.MULTILINE)
test_str = ("<p style=“text-align:center; others-style:value;”>Content</p>\n"
"<div style=‘text-align:left; others-style:value;’ class=‘any class’>Any Content That You Wish</div><p style=“text-align:center; others-style:value;”>Content</p>")
subst = "<\\2>\\3</\\2>"
result = regex.sub(subst, test_str)
if result:
print(result)