#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=lyrics-eng=)(?:[\w ]+\s)+"
Local $sString = ";FFMETADATA1" & @CRLF & _
"album=name of the album" & @CRLF & _
"artist=name of the artist" & @CRLF & _
"title=name of the title" & @CRLF & _
"lyrics-eng=line1 of lyrics" & @CRLF & _
"line2 of lyrics" & @CRLF & _
"line3 of lyrics" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")