import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=lyrics-eng=)(?:[\\w ]+\\s)+";
final String string = ";FFMETADATA1\n"
+ "album=name of the album\n"
+ "artist=name of the artist\n"
+ "title=name of the title\n"
+ "lyrics-eng=line1 of lyrics\n"
+ "line2 of lyrics\n"
+ "line3 of lyrics\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}