re = /(?<=lyrics-eng=)(?:[\w ]+\s)+/m
str = ';FFMETADATA1
album=name of the album
artist=name of the artist
title=name of the title
lyrics-eng=line1 of lyrics
line2 of lyrics
line3 of lyrics
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end