const regex = /(?<=lyrics-eng=)(?:[\w ]+\s)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=lyrics-eng=)(?:[\\w ]+\\s)+', 'gm')
const str = `;FFMETADATA1
album=name of the album
artist=name of the artist
title=name of the title
lyrics-eng=line1 of lyrics
line2 of lyrics
line3 of lyrics
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}