using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=lyrics-eng=)(?:[\w ]+\s)+";
string input = @";FFMETADATA1
album=name of the album
artist=name of the artist
title=name of the title
lyrics-eng=line1 of lyrics
line2 of lyrics
line3 of lyrics
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}