#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:v(?:s?\.|:)?)\s*(.*)"
Local $sString = "Zinaida Shumilina et al. v. Belarus " & @CRLF & _
" " & @CRLF & _
"CCPR/C/120/D/2142/2012" & @CRLF & _
"K.E.R. vs. Canada " & @CRLF & _
" " & @CRLF & _
"CCPR/C/120/D/2196/2012 " & @CRLF & _
"Lounis Khelifati v Algeria " & @CRLF & _
" " & @CRLF & _
"CCPR/C/120/D/2267/2013" " & @CRLF & _
"Hibaq Said Hash v. Denmark " & @CRLF & _
" " & @CRLF & _
"CCPR/C/120/D/2470/2014" " & @CRLF & _
"Anton Batanov v. Russian Federation " & @CRLF & _
" " & @CRLF & _
"CCPR/C/120/D/2532/2015"" & @CRLF & _
"S. Z. v. Denmark " & @CRLF & _
" " & @CRLF & _
"CCPR/C/120/D/2625/2015" " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")