use strict;
my $str = 'Zinaida Shumilina et al. v. Belarus
CCPR/C/120/D/2142/2012
K.E.R. vs. Canada
CCPR/C/120/D/2196/2012
Lounis Khelifati v Algeria
CCPR/C/120/D/2267/2013"
Hibaq Said Hash v. Denmark
CCPR/C/120/D/2470/2014"
Anton Batanov v. Russian Federation
CCPR/C/120/D/2532/2015"
S. Z. v. Denmark
CCPR/C/120/D/2625/2015"
';
my $regex = qr/\b(?:v(?:s?\.|:)?)\s*(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}