using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:v(?:s?\.|:)?)\s*(.*)";
string input = @"Zinaida Shumilina et al. v. Belarus
CCPR/C/120/D/2142/2012
K.E.R. vs. Canada
CCPR/C/120/D/2196/2012
Lounis Khelifati v Algeria
CCPR/C/120/D/2267/2013""
Hibaq Said Hash v. Denmark
CCPR/C/120/D/2470/2014""
Anton Batanov v. Russian Federation
CCPR/C/120/D/2532/2015""
S. Z. v. Denmark
CCPR/C/120/D/2625/2015""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}