$re = '/\b(?:v(?:s?\.|:)?)\s*(.*)/';
$str = 'Zinaida Shumilina et al. v. Belarus
CCPR/C/120/D/2142/2012
K.E.R. vs. Canada
CCPR/C/120/D/2196/2012
Lounis Khelifati v Algeria
CCPR/C/120/D/2267/2013"
Hibaq Said Hash v. Denmark
CCPR/C/120/D/2470/2014"
Anton Batanov v. Russian Federation
CCPR/C/120/D/2532/2015"
S. Z. v. Denmark
CCPR/C/120/D/2625/2015"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);