import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:v(?:s?\\.|:)?)\\s*(.*)";
final String string = "Zinaida Shumilina et al. v. Belarus \n"
+ " \n"
+ "CCPR/C/120/D/2142/2012\n"
+ "K.E.R. vs. Canada \n"
+ " \n"
+ "CCPR/C/120/D/2196/2012 \n"
+ "Lounis Khelifati v Algeria \n"
+ " \n"
+ "CCPR/C/120/D/2267/2013\" \n"
+ "Hibaq Said Hash v. Denmark \n"
+ " \n"
+ "CCPR/C/120/D/2470/2014\" \n"
+ "Anton Batanov v. Russian Federation \n"
+ " \n"
+ "CCPR/C/120/D/2532/2015\"\n"
+ "S. Z. v. Denmark \n"
+ " \n"
+ "CCPR/C/120/D/2625/2015\" \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}