#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(carfax|((yandex-)?auto-vin-decoder))-.+"
Local $sString = "yandex-auto-vin-decoder-scheduler" & @CRLF & _
"auto-vin-decoder-api" & @CRLF & _
"carfax-consumers" & @CRLF & _
"yandex-carfax-consumers-bla" & @CRLF & _
"yandex-auto-vin-decoder-recalls-api"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")