package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(carfax|((yandex-)?auto-vin-decoder))-.+`)
var str = `yandex-auto-vin-decoder-scheduler
auto-vin-decoder-api
carfax-consumers
yandex-carfax-consumers-bla
yandex-auto-vin-decoder-recalls-api`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}