re = /^(carfax|((yandex-)?auto-vin-decoder))-.+/m
str = 'yandex-auto-vin-decoder-scheduler
auto-vin-decoder-api
carfax-consumers
yandex-carfax-consumers-bla
yandex-auto-vin-decoder-recalls-api'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end