$re = '/^(carfax|((yandex-)?auto-vin-decoder))-.+/m';
$str = 'yandex-auto-vin-decoder-scheduler
auto-vin-decoder-api
carfax-consumers
yandex-carfax-consumers-bla
yandex-auto-vin-decoder-recalls-api';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);