const regex = /^(carfax|((yandex-)?auto-vin-decoder))-.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(carfax|((yandex-)?auto-vin-decoder))-.+', 'gm')
const str = `yandex-auto-vin-decoder-scheduler
auto-vin-decoder-api
carfax-consumers
yandex-carfax-consumers-bla
yandex-auto-vin-decoder-recalls-api`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}