import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(carfax|((yandex-)?auto-vin-decoder))-.+";
final String string = "yandex-auto-vin-decoder-scheduler\n"
+ "auto-vin-decoder-api\n"
+ "carfax-consumers\n"
+ "yandex-carfax-consumers-bla\n"
+ "yandex-auto-vin-decoder-recalls-api";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}