#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xs)(['"])(?:(?!\1|\\).|\\.)*\1 #duscard quoted string first" & @CRLF & _
"|\/\/[^\n\r]* # capture single line comments before mutli-line" & @CRLF & _
"|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/ #c-style multi-line comment" & @CRLF & _
"|(StringsToBeSearched)"
Local $sString = "someString = "An StringsToBeSearched example comment: /* example */";" & @CRLF & _
"" & @CRLF & _
"// The comment around this code has been commented out. StringsToBeSearched" & @CRLF & _
"// /*" & @CRLF & _
"some_code();" & @CRLF & _
"// */" & @CRLF & _
"" & @CRLF & _
"/* " & @CRLF & _
" * a proper multiline comment:StringsToBeSearched" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"StringsToBeSearched"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")