import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(['\"])(?:(?!\\1|\\\\).|\\\\.)*\\1 #duscard quoted string first\n"
+ "|\\/\\/[^\\n\\r]* # capture single line comments before mutli-line\n"
+ "|\\/\\*[^*]*\\*+(?:[^\\/*][^*]*\\*+)*\\/ #c-style multi-line comment\n"
+ "|(StringsToBeSearched)";
final String string = "someString = \"An StringsToBeSearched example comment: /* example */\";\n\n"
+ "// The comment around this code has been commented out. StringsToBeSearched\n"
+ "// /*\n"
+ "some_code();\n"
+ "// */\n\n"
+ "/* \n"
+ " * a proper multiline comment:StringsToBeSearched\n"
+ " */\n\n\n"
+ "StringsToBeSearched";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}