const regex = /(['"])(?:(?!\1|\\).|\\.)*\1 #duscard quoted string first
|\/\/[^\n\r]* # capture single line comments before mutli-line
|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/ #c-style multi-line comment
|(StringsToBeSearched)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\'"])(?:(?!\\1|\\\\).|\\\\.)*\\1 #duscard quoted string first
|\\\/\\\/[^\\n\\r]* # capture single line comments before mutli-line
|\\\/\\*[^*]*\\*+(?:[^\\\/*][^*]*\\*+)*\\\/ #c-style multi-line comment
|(StringsToBeSearched)', 'gs')
const str = `someString = "An StringsToBeSearched example comment: /* example */";
// The comment around this code has been commented out. StringsToBeSearched
// /*
some_code();
// */
/*
* a proper multiline comment:StringsToBeSearched
*/
StringsToBeSearched`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}