$re = '/([\'"])(?:(?!\1|\\\\).|\\\\.)*\1 #duscard quoted string first
|\/\/[^\n\r]* # capture single line comments before mutli-line
|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/ #c-style multi-line comment
|(StringsToBeSearched)/xs';
$str = 'someString = "An StringsToBeSearched example comment: /* example */";
// The comment around this code has been commented out. StringsToBeSearched
// /*
some_code();
// */
/*
* a proper multiline comment:StringsToBeSearched
*/
StringsToBeSearched';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);