re = /(['"])(?:(?!\1|\\).|\\.)*\1 #duscard quoted string first
|\/\/[^\n\r]* # capture single line comments before mutli-line
|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/ #c-style multi-line comment
|(StringsToBeSearched)/x
str = 'someString = "An StringsToBeSearched example comment: /* example */";
// The comment around this code has been commented out. StringsToBeSearched
// /*
some_code();
// */
/*
* a proper multiline comment:StringsToBeSearched
*/
StringsToBeSearched'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end