using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""])(?:(?!\1|\\).|\\.)*\1 #duscard quoted string first
|\/\/[^\n\r]* # capture single line comments before mutli-line
|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/ #c-style multi-line comment
|(StringsToBeSearched)";
string input = @"someString = ""An StringsToBeSearched example comment: /* example */"";
// The comment around this code has been commented out. StringsToBeSearched
// /*
some_code();
// */
/*
* a proper multiline comment:StringsToBeSearched
*/
StringsToBeSearched";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}