#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^```(?:\w+)?\s*\n(.*?)(?=^```)```"
Local $sString = "Lorem ipsum" & @CRLF & _
"```python" & @CRLF & _
"print('foo```bar```foo')" & @CRLF & _
"print('foo```bar```foo')" & @CRLF & _
"```" & @CRLF & _
"Lorem ipsum" & @CRLF & _
"```python" & @CRLF & _
"print('foo```bar```foo')" & @CRLF & _
"print('foo```bar```foo')" & @CRLF & _
"```" & @CRLF & _
"Lorem ipsum" & @CRLF & _
"```" & @CRLF & _
"print('foo```bar```foo')" & @CRLF & _
"print('foo```bar```foo')" & @CRLF & _
"```" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")