const regex = new RegExp('^```(?:\\w+)?\\s*\\n(.*?)(?=^```)```', 'gms')
const str = `Lorem ipsum
\`\`\`python
print('foo\`\`\`bar\`\`\`foo')
print('foo\`\`\`bar\`\`\`foo')
\`\`\`
Lorem ipsum
\`\`\`python
print('foo\`\`\`bar\`\`\`foo')
print('foo\`\`\`bar\`\`\`foo')
\`\`\`
Lorem ipsum
\`\`\`
print('foo\`\`\`bar\`\`\`foo')
print('foo\`\`\`bar\`\`\`foo')
\`\`\`
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}